وردپرس فونت های میزبانی شده محلی را برای تم های پیش فرض قدیمی تا نسخه 6.2 منتشر می کند – WP Tavern


در ژوئن 2022، تیم Themes WordPress.org به شدت از نویسندگان مضمون خواست تا به وب‌فونت‌های میزبانی محلی روی آورند، پس از یک پرونده قضایی آلمانی، که مالک وب‌سایت را به دلیل نقض GDPR با استفاده از وب فونت‌های میزبانی شده توسط Google جریمه کرد. برای سال‌ها، نویسندگان تم فونت‌های Google را از CDN گوگل برای عملکرد بهتر در صف قرار می‌دهند، اما این روش آدرس‌های IP بازدیدکنندگان را نشان می‌دهد.

تیم Themes هشدار داد که دستورالعمل‌های مربوط به فونت‌های میزبانی محلی به‌زودی تغییر می‌کنند و بسیاری از نویسندگان مضمون قبل از تبدیل شدن به یک الزام برای رعایت آن اقدام کردند.

آ بلیط برای بسته‌بندی فونت‌های Google با تم‌های پیش‌فرض قدیمی وردپرس دارای وصله‌هایی بود و قرار بود در ماه نوامبر در وردپرس 6.1 گنجانده شود. مشارکت کننده وردپرس هندریک لوهرسن درخواست کرد بیشتر به این بلیط نگاه می کنند و می گویند که “مستقیما بر مخاطبان اصلی وردپرس در آلمان تأثیر می گذارد.” او گزارش داد که کاربران در آلمان همچنان ایمیل هایی دریافت می کنند که برای استفاده از فونت های بارگذاری شده از گوگل جریمه می شوند.

کامیتر هسته وردپرس تونیا مورک پیشنهادی در حال بررسی انتشار نسخه به روز شده هر تم به طور جداگانه از وردپرس 6.1.

مورک گفت: «وقتی هر طرح زمینه آماده شد، آن را در مخزن تم wp.org منتشر کنید. “کاربران می توانند قبل از انتشار WP 6.1 فونت های میزبان محلی را به روز کنند.”

این مسیر بلیط را تغییر داد و با بررسی بیشتر، مشارکت کنندگان دریافتند که وصله ها می توانند از کارهای بیشتری استفاده کنند.

«ایجاد نسخه‌های تم جدید برای این تغییر خاص می‌تواند خوب باشد زمانی که آنها آماده هستنداستفان برنهارت گفت. “استفاده از فونت های میزبانی محلی قبلاً توصیه می‌شود، اما قبل از اینکه بتوانیم این مورد را برای دیگران الزامی کنیم، باید مضامین خود را اصلاح کنیم.» او پس از بررسی وصله ها لیستی از مشکلات و پیشرفت های احتمالی را ارائه کرد و مشارکت کنندگان در حال کار روی رویکرد بهتری هستند.

دیوید باوموالد، متولی اصلی وردپرس نقطه عطف را به 6.2 تغییر داد، از آنجایی که نسخه بتای 2 برای نسخه 6.1 دیروز منتشر شد و بلیط هنوز به یک جهت و پچ نهایی نیاز دارد.

لوهرسن گفت: «در حالی که من موضوع را درک می کنم، با این وجود دیدن این موضوع ناراحت کننده است. “این هنوز یک مشکل جدی در آلمان (و سایر مناطق GDPR) است، زیرا کاربران با فونت های فعال گوگل در حال حاضر هدف قرار گرفتن توسط افرادی که از قانون سوء استفاده می کنند

لوهرسن در توییتر به اظهار نظر در مورد ناامیدی خود از بلیط از دست دادن پنجره برای 6.1.

او گفت: “این دلیلی است که وردپرس احتمالاً ارتباط خود را از دست می دهد.” «کاربران واقعی در اینجا آسیب می بینند، اما آنها در قلمروهای GDPR هستند و به نظر می رسد این مهم نیست.

«آیا می‌توانستم کارهای بیشتری انجام دهم؟ شاید. اما تا حدودی غم انگیز است که می بینیم سرعت آن بلیط چقدر سریع از بین رفت. اگر Squarespace، Wix و Sort شروع به بازاریابی حریم خصوصی در برابر وردپرس کنند، ما در کشورهای GDPR دچار مشکل شده ایم.

در این بین، کسانی که از تم های پیش فرض وردپرس استفاده می کنند، می توانند از افزونه ای مانند استفاده کنند فونت های محلی گوگل یا OMGF | مطابق با GDPR/DSVGO، فونت های گوگل سریعتر برای میزبانی فونت ها به صورت محلی

کاربران همچنین می توانند به فونت های اسم حیوان دست اموز، یک پلت فرم فونت وب منبع باز و حریم خصوصی، بدون ردیابی یا ثبت گزارش که کاملاً مطابق با GDPR است. Bunny Fonts با Google Fonts CSS v1 API سازگار است، بنابراین می تواند به عنوان یک جایگزین کشویی عمل کند. این فونت های گوگل را با فونت های Bunny جایگزین کنید این افزونه انجام این کار را بدون ویرایش هیچ کدی برای کاربران آسان می کند.

مشارکت‌کنندگان در حال کار بر روی داشتن تم‌های پیش‌فرض وردپرس کاملاً منطبق با GDPR برای وردپرس 6.2 هستند که در اوایل سال 2023 انتظار می‌رود.




منبع: https://wptavern.com/wordpress-punts-locally-hosted-fonts-for-legacy-default-themes-to-6-2-release