دو افزونه جدید وردپرس دسترسی ویرایشگر بلوک و انطباق با WCAG را بهبود می بخشد – WP Tavern


وردپرس Core Committer Jb Audras، CTO در فرانسه Whodunit آژانس، دو پلاگین دسترسی جدید را با همکاری Guillaume Turpin، یکی دیگر از توسعه دهندگان تیم Whodunit منتشر کرده است. اینها افزونه‌های کوچک «میکرو» هستند که برای پر کردن شکاف‌های موجود در تجربه ایجاد محتوای قابل دسترس ویرایشگر بلوک توسعه یافته‌اند.

پلاگین اول نام دارد ویژگی زبان برای ویرایشگر بلوک و برای محتوایی که به چندین زبان نوشته شده است مهم است. این به سازندگان محتوا اجازه می دهد تا تغییرات زبان را با استفاده از ویژگی lang نشان دهند تا کسانی که از فناوری های کمکی استفاده می کنند قوانین ارائه و تلفظ صحیح را برای زبان مشخص شده دریافت کنند. این افزونه به سایت‌های وردپرسی کمک می‌کند تا الزامات معیار موفقیت WCAG 3.1.2 «زبان قطعات» را برآورده کنند.

با نصب افزونه، سازندگان محتوا می توانند متن را برجسته کرده و سپس ویژگی زبان را در نوار ابزار بلوک برای ویرایش آن پیدا کنند.

“شایان ذکر است که نشان دادن تغییرات زبان در محتوا برای انطباق با WCAG اجباری است، و در حال حاضر هیچ راهی برای انجام این کار در ویرایشگر Block (به جز ویرایش دستی کد) وجود ندارد.” گفت هنگام معرفی افزونه در توییتر. “من فکر می کنم این ویژگی باید به صورت بومی در گوتنبرگ پیاده سازی شود.”

پلاگین میکرو دوم نام دارد دکمه اختصاری برای ویرایشگر بلوک، که به نویسندگان محتوا اجازه می دهد تا با استفاده از عنصر HTML تعاریفی را برای اختصارات درج کنند. این به بازدیدکنندگان سایت امکان می‌دهد به شکل گسترش یافته اختصارات، همانطور که توسط مشخص شده است، دسترسی داشته باشند معیار موفقیت WCAG 3.1.4 “اختصارات”.

WCAG چند نوع بازدیدکننده را شناسایی می کند که ممکن است با اختصارات به آنها کمک کند، از جمله کسانی که در رمزگشایی کلمات مشکل دارند، کسانی که به ذره بین های صفحه متکی هستند، حافظه محدودی دارند و کسانی که در استفاده از زمینه برای کمک به درک مشکل دارند.

تگ مخفف را می‌توان در نوار ابزار بلوک نیز یافت، بنابراین کاربران می‌توانند هر متنی را که می‌خواهند شکل گسترده‌شده اختصاری را برای آن ارائه کنند، برجسته کنند.

هر دو دکمه مخفف و ویژگی زبان افزونه ها به صورت رایگان در فهرست افزونه های وردپرس در دسترس هستند. سازندگان افزونه ها امیدوارند که برخی از این قابلیت ها در نهایت به ویرایشگر بلوک اضافه شود، اما در این بین کاربران می توانند افزونه ها را نصب کنند تا محتوای قابل دسترس تری ایجاد کنند که دستورالعمل های دسترسی را رعایت کند.




منبع: https://wptavern.com/two-new-wordpress-plugins-improve-block-editor-accessibility-and-wcag-compliance